Monday, August 1, 2011

Opening Day Fun and Games!

What follows is the transcript of an email I sent to my tech dept at school today just so you can see what fun we are having already:

Dear Anonymous,

First off, thanx so much for all your help these past 2 days! I couldn't have gotten all 25 new PCs up and running without your assistance. Unfortunately, there's still some issues:

(1) The Good: aka what went right
I did a quick and simple 32bit Ubuntu 10.10 install on all the student stations. As I had a lot of meetings to go to as well, I didn't have a lot of time to play around. So, I basically just wiped all 250GB of each hdd and made a single partition. The only thing I configured was eth0 with static IPs from thru plus netmask, gateway and dns. We no longer have dual partitions nor do we have dual NICs. Gone are the days of dual boot I suppose....

(2) The Bad: aka stuff that didn't go right
The two Linux servers cannot surf! Intranet (ie ping) works, so the students can do their work using ftp and ssh. I tried, and but had no joy. Firefox complained about not finding a DNS server and Chrome complained about finding no proxy server. My students can login to the servers in school and from home, but I need to surf in order to maintain these servers. Also, I need to make one of them into a LAMP server in order to run SAGE locally. For this, I need to download and configure a lot of utilities that are hard to acquire without being able to surf the internet!

IIRC, the servers are:

(3) The Ugly: aka what needs fixing first
(3a) PC 25, the Teacher Station, needs to be a dual boot box. I need Linux to teach and Windows for lots of legacy files on my h: drive. For example, I have literally 1000s of pages I've written over the years in Word using the inline Equation Editor (like TEX) that do not auto convert in OpenOffice. I simply don't have the time to retype all that stuff!
(3b) The SmartBoard will not power on even though the projector does. The green power switch is not lit and the board surface does not react to pens or touch. worked yesterday.
(3c) The network printer was not found whenever I tried to enable printing on any of the new boxes.

You asked about DHCP. We've used it before, but I don't know if it was on VLAN5 or not. I assume you want to use DHCP for the Windows partition and a static IP for the Linux partition. is the static IP I have been using for the Teacher Station.

A few more notes:
(1) I used the Linux on the Teacher Station ( all day today to drive my SmartBoard and for a presentation at a meeting. I had to do this with a Linux CD since I couldn't install that station while I was waiting for the Windows partition to be reimaged so I could setup a dual boot box.

(2) There are two power switches at the front of the room that are supposed to cut power to all the Student Stations if necessary. The right switch kills the right side of the room and the left switch used to kill the left side of the room. The left switch only kills thru, is there anyway we could repair this switch so it cuts power to + as it once did?

(3) We have a bit of water damage to the ceiling, due to Hurricane Irene, especially in the front left section of the room. We need to repair that too!

I hope you had better luck on your first day back to school! 

Teaching with Technology, 

No comments:

Post a Comment